500 Illegal PORT command

Fragen und Antworten (eine Art Faq) zu unseren Server Umzug

Moderator: mane

Jordi
Administrator
Beiträge: 157
Registriert: 10.11.2007, 18:09
Kontaktdaten:

500 Illegal PORT command

Beitragvon Jordi » 01.11.2008, 23:34

Hallo,

Mit meinem Haupt-PC klappt die FTP-Verbindung zu homepage.weihenstephan.org, aber nicht mit einem Netzwerk-PC, der über den Haupt-PC (ohne Router) auf das Internet zugreift. Hier erhalte ich in Total Commander die Fehlermeldung "500 Illegal PORT command":

Code: Alles auswählen

Connect to: (01.11.2008 13:39:41)
hostname=homepage.weihenstephan.org
username=XXX
startdir=
homepage.weihenstephan.org=78.47.36.17
220 ProFTPD 1.3.1 Server (ProFTPD) [78.47.36.17]
USER XXX
331 Password required for XXX
PASS ***********
230 User XXX logged in
SYST
215 UNIX Type: L8
FEAT
211-Features:
 MDTM
 REST STREAM
 SIZE
211 End
Connect ok!
PWD
257 "/" is the current directory
Verzeichnis einlesen
TYPE A
200 Type set to A
PORT XXX
500 Illegal PORT command
PASV
227 Entering Passive Mode (78,47,36,17,175,40).
PORT XXX
500 Illegal PORT command
QUIT
221 Goodbye.

Passive Mode habe ich schon vergeblich ausprobiert. Kann es sein, daß es an der Server-Konfiguration liegt?
Werner Schwarz (Moosburg Online)

hermrohr

Re: 500 Illegal PORT command

Beitragvon hermrohr » 02.11.2008, 13:10

Hast du es schonmal mit aktiven FTP anstatt passivem FTP versucht? :-)

Jordi
Administrator
Beiträge: 157
Registriert: 10.11.2007, 18:09
Kontaktdaten:

Re: 500 Illegal PORT command

Beitragvon Jordi » 02.11.2008, 17:19

hermrohr hat geschrieben:Hast du es schonmal mit aktiven FTP anstatt passivem FTP versucht? :-)

Ja, das war ja die Ausgangseinstellung. :wink: Passiv hatte ich nur probiert, weil ich irgendwo gelesen hatte, daß es etwas bringen soll.

Hier lese ich:

Das bedeutet, dass im FTP-Server der Boxen der FxP-Modus (Server zu Server) deaktiviert ist. Das sollte sich im Prinzip in der Konfiguration des Servers einstellbar sein.

Sagt Dir das etwas?
Werner Schwarz (Moosburg Online)

hermrohr
Mitglied
Beiträge: 11
Registriert: 02.11.2008, 13:13

Re: 500 Illegal PORT command

Beitragvon hermrohr » 02.11.2008, 18:41

Nein... nicht so direkt. Aber das ist eigentlich hier vollkommen irrelevant. Gehts denn inzwischen wieder?

Jordi
Administrator
Beiträge: 157
Registriert: 10.11.2007, 18:09
Kontaktdaten:

Re: 500 Illegal PORT command

Beitragvon Jordi » 02.11.2008, 19:06

Äh nein, es ging vor der Umstellung, und auch andere Server funktionieren, nur der neue vom BNW nicht.
Werner Schwarz (Moosburg Online)

hermrohr
Mitglied
Beiträge: 11
Registriert: 02.11.2008, 13:13

Re: 500 Illegal PORT command

Beitragvon hermrohr » 02.11.2008, 19:12

Hast du schonmal versucht, einen anderen FTP-Client wie z.B. den Filezilla? http://www.filezilla.de/
Also zumindest mal zu Diagnosezwecken... Weil generell funktioniert der FTP-Server. Ich habe es gerade extra nochmals getestet.

Jordi
Administrator
Beiträge: 157
Registriert: 10.11.2007, 18:09
Kontaktdaten:

Re: 500 Illegal PORT command

Beitragvon Jordi » 02.11.2008, 19:34

Das war jetzt Gedankenübertragung, denn inzwischen habe ich Filezilla installiert, und dort die Transfermodi standard, aktiv und passiv durchprobiert: 500 Illegal PORT command kommt zwar (bei aktiv), aber es läuft weiter, bis es nach LIST abbricht (auch bei standard und passiv):

Code: Alles auswählen

LIST
Zeitüberschreitung der Verbindung

Wie gesagt, das betrifft nur Rechner, die keine direkte ADSL-Verbindung haben, sondern über LAN verbunden sind.
Werner Schwarz (Moosburg Online)

Jordi
Administrator
Beiträge: 157
Registriert: 10.11.2007, 18:09
Kontaktdaten:

Re: 500 Illegal PORT command

Beitragvon Jordi » 03.11.2008, 17:49

Hallo,

ich hatte auch im Total Commander Forum gefragt, und dort jetzt zur Antwort bekommen:

Dem Server den Passivmodus beibringen, oder einen Proxy verwenden...

Das mit dem Proxy ist mir ehrlich gesagt zu kompliziert, deshalb wäre es schön, wenn der erste Vorschlag funktionieren würde. :)
Werner Schwarz (Moosburg Online)

hermrohr
Mitglied
Beiträge: 11
Registriert: 02.11.2008, 13:13

Re: 500 Illegal PORT command

Beitragvon hermrohr » 03.11.2008, 18:49

Hmm... [ironie]ich hab nix getan und jetzt gehts ;-) [/irone]
Frag mich bitte nicht weshalb, aber er hat einfach eine Einstellung verloren....

Jordi
Administrator
Beiträge: 157
Registriert: 10.11.2007, 18:09
Kontaktdaten:

Re: 500 Illegal PORT command

Beitragvon Jordi » 03.11.2008, 19:33

Super, danke! :D
Werner Schwarz (Moosburg Online)

[email protected]
Mitglied
Beiträge: 9
Registriert: 04.12.2009, 16:30
Wohnort: Mauern, 85419
Kontaktdaten:

Re: 500 Illegal PORT command

Beitragvon [email protected] » 04.12.2009, 16:51

Hast du vlt. nicht den Port 21 verwendet?

Oder ist deine Firewall für den Port nicht geöffnet?

Welches Betriebssystem verwendest du?

Linux, Windows, usw.

Mfg

Joseph

Jordi
Administrator
Beiträge: 157
Registriert: 10.11.2007, 18:09
Kontaktdaten:

Re: 500 Illegal PORT command

Beitragvon Jordi » 05.12.2009, 11:22

Hallo Joseph,

danke für den Hinweis, aber es lag definitiv am Server, nicht an der eigenen Konfiguration (XP SP3, ohne Fremd-Firewall). Mittlerweile bin ich umgezogen und habe einen Router, so daß das Problem ohnehin nicht mehr auftritt.
Werner Schwarz (Moosburg Online)


Zurück zu „Umstellung 2008“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast